| |

VerySource

 Forgot password?
 Register
Search
View: 103|Reply: 5

Using show processlist, I found that the database connection has been Reading from net, what should I do?

[Copy link]

1

Threads

9

Posts

10.00

Credits

Newbie

Rank: 1

Credits
10.00

 United States

Post time: 2020-1-16 13:00:01
| Show all posts |Read mode
Using show processlist, I found that the database connection has been Reading from net, what should I do?
http://dev.mysql.com/doc/refman/4.1/en/show-processlist.html
Reading from net
The server is reading a packet from the network.

The explanation from the mysql official website is as above, but I don't know how to avoid this phenomenon?
And what is the reason for this phenomenon?
Reply

Use magic Report

0

Threads

20

Posts

17.00

Credits

Newbie

Rank: 1

Credits
17.00

 China

Post time: 2020-3-7 10:30:01
| Show all posts
can not avoid.
Reply

Use magic Report

1

Threads

9

Posts

10.00

Credits

Newbie

Rank: 1

Credits
10.00

 Canada

 Author| Post time: 2020-3-12 18:30:01
| Show all posts
But why is this happening?
If it is used normally, it should be used up and go to sleep.
If this happens all the time, the CPU will be very busy
Reply

Use magic Report

1

Threads

9

Posts

10.00

Credits

Newbie

Rank: 1

Credits
10.00

 China

 Author| Post time: 2020-8-10 19:30:01
| Show all posts
Top oneself
Reply

Use magic Report

0

Threads

1

Posts

2.00

Credits

Newbie

Rank: 1

Credits
2.00

 China

Post time: 2020-8-15 18:30:02
| Show all posts
up
Reply

Use magic Report

0

Threads

1

Posts

2.00

Credits

Newbie

Rank: 1

Credits
2.00

 China

Post time: 2020-8-29 21:00:01
| Show all posts
This is a special setting on an official system, just treat it as a bug in mysql
Regardless of whether the method of linking is through hosts or IP, it will do a reverse check on DNS
mysqld will try to reverse-check IP -> dns. Because the reverse-check resolution is too slow, it will not be able to cope with excessive queries.



Solution:

/usr/local/mysql/bin/mysqld_safe --skip-name-resolve --user=mysql&

Just add --skip-name-resolve such a parameter, turn off the dns reverse check function of mysql.
Reply

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Contact us|Archive|Mobile|CopyRight © 2008-2020|verysource.com ( 京ICP备17048824号-1 )

Quick Reply To Top Return to the list