| |

VerySource

 Forgot password?
 Register
Search
Author: happyls

in oracle, i can't insert into Chinese

[Copy link]

0

Threads

66

Posts

45

Credits

Newbie

Rank: 1

Credits
45

 China

Post time: 2020-5-10 00:15:01
| Show all posts
In your client registry ORACLE, change the value of NLS_LANG to WE8ISO8859P1
Just
Reply

Use magic Report

0

Threads

10

Posts

10

Credits

Newbie

Rank: 1

Credits
10

 China

Post time: 2020-5-10 13:30:01
| Show all posts
Search the NLS_LANG key in the Windows registry (regedit) and change the key value to: WE8ISO8859P1
Reply

Use magic Report

1

Threads

7

Posts

5

Credits

Newbie

Rank: 1

Credits
5

 China

 Author| Post time: 2020-5-10 15:45:01
| Show all posts
I changed the value of nls_lang in oracle to "WE8ISO8859P1", (and restarted the client) or not?
Reply

Use magic Report

1

Threads

7

Posts

5

Credits

Newbie

Rank: 1

Credits
5

 China

 Author| Post time: 2020-5-10 20:30:01
| Show all posts
My main thing is that the program cannot be inserted into Chinese. The client insert is used first to make sure that the garbled characters are not caused by the program. Is it a server configuration problem?
Reply

Use magic Report

0

Threads

66

Posts

45

Credits

Newbie

Rank: 1

Credits
45

 China

Post time: 2020-5-11 09:30:01
| Show all posts
Can the client display Chinese now?
Your problem is probably to reinstall oracle. When choosing the language when installing, choose:

AMERICAN_AMERICA.ZHS16GBK
Reply

Use magic Report

1

Threads

7

Posts

5

Credits

Newbie

Rank: 1

Credits
5

 China

 Author| Post time: 2020-5-11 15:00:01
| Show all posts
I changed all the values ​​of nls_lang in regedit to "WE8ISO8859P1", and now the client can not enter, it says: "invalid or unknow NLS parameter value specified"
Reply

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Contact us|Archive|Mobile|CopyRight © 2008-2020|verysource.com ( 京ICP备17048824号-1 )

Quick Reply To Top Return to the list